Hướng dẫn cấu hình bgp

Cmùi hương 12: CƠ BẢN HOẠT ĐỘNG CỦA BGPhường (Phần 1) -

Cmùi hương 12: CƠ BẢN HOẠT ĐỘNG CỦA BGPhường. (Phần 1) -

Cmùi hương 12: CƠ BẢN HOẠT ĐỘNG CỦA BGPhường (Phần 1) - Chương 12: CƠ BẢN HOẠT ĐỘNG CỦA BGP (Phần 1) - Chương 12: CƠ BẢN HOẠT ĐỘNG CỦA BGPhường. (Phần 1) -
*

Follow us :
*
*
*
*



*

BGP. là chủ thể đặc trưng tốt nhất trong cả kỳ thi CCIE triết lý và kỳ thi thực hành thực tế. Cmùi hương này thể hiện có tác dụng thế nào BGP kết thúc các tác vụ cơ bản:

Hình thành các tình dục bóng giềng.Đưa tuyến đường vào BGPhường trường đoản cú các nguồn khác nhau.Trao đổi các những tuyến với các router khác.Đưa con đường vào trong bảng định tuyến đường.

Bạn đang xem: Hướng dẫn cấu hình bgp

Mặc cho dù những chủ thể này có một sự tương đồng với rất nhiều giao thức IGPhường. tại mức toàn diện, tuy thế ví như xét trong vòng cụ thể, đương nhiên là có không ít sự biệt lập.

Chương thơm này tập trung trình bày BGP. triển khai các tác vụ của một giao thức định tuyến. Chương thơm 13 đang diễn tả những chế độ định tuyến đường, chỉ ra những cách làm được dùng bởi BGPhường. để số lượng giới hạn và thay đổi các cỗ lọc đường, chỉ ra các BGPhường chọn ra tuyến cực tốt giữa các đường thuộc trở về một mạng nào đó.

I. GIỚI THIỆU

Cũng y như các giao thức nội (IGP), BGPhường. dàn xếp các thông báo về sơ đồ vật mạng để ở đầu cuối, những router học tập được lối đi tốt nhất có thể về một tập đúng theo những can hệ mạng. Không y như IGP, BGP ko dùng khái niệm ngân sách nhằm lựa chọn lối đi tốt nhất có thể giữa các lựa chọn không giống nhau về cùng một mạng đích. Thay vào đó, BGP. sử dụng vài ba thuộc tính về đường đi (path attibutes – PA) với một các bước ra ra quyết định tương quan.

BGP.. dùng trực thuộc tính đường dẫn khối hệ thống tự trị (autonomous system path - AS_PATH) như thể ở trong tính khoác định Lúc không có thuộc tính nào khác được tùy chỉnh và cấu hình. Nói bình thường, BGP dùng các nằm trong tính về đường đi để trình bày điểm sáng của một tuyến.

Thuộc tính AS_PATH sẽ liệt kê đường truyền, được có mang là 1 chuỗi những số hiệu mạng mà lại một gói tin bắt buộc trải qua để mang đến một mạng đích làm sao đó. Hình 12.1 là một ví dụ.

*

Hình 12.1: Mô tả việc chọn lựa lối đi của BGP

Hình 12.1 biểu thị một trường thích hợp cổ điển trong đó BGPhường dùng vector đường dẫn (path vector) để chọn con đường. Trong hình, R1 học tập hai giá trị AS_PATH để hoàn toàn có thể mang đến được mạng 9.0.0.0/8 - thông qua ASN 2-3 và trải qua qua ASN 5-4-3.

Nếu không tồn tại router như thế nào cần sử dụng cơ chế định tuyến đường để tác động mang lại các ở trong tính không giống nhằm mục tiêu biến đổi tuyển lựa con đường làm sao tốt nhất, R1 sẽ chọn tuyến gồm AS_PATH ngắn thêm tốt nhất, trong trường vừa lòng này là AS_PATH 2-3.

BGPhường xem nằm trong tính AS_PATH như là một vector với chiều dài của vector (là số AS trong con đường đi) khẳng định đường đi tốt nhất. Trong BGP, thuật ngữ tuyến đường vẫn nhằm ám chỉ mang lại các tuyến IPhường. theo từng trạm mà lại thuật ngữ băng thông ao ước chỉ mang đến một chuỗi các cực hiếm AS được dùng để làm đến một thúc đẩy đích đặc trưng.

Chương này vẫn biểu thị theo một thứ từ bỏ tương tự như như những cmùi hương trước. Đầu tiên vẫn triệu tập vào câu hỏi cấu hình thiết lập quan hệ nhẵn giềng, tiếp nối sẽ trình bày BGPhường. thương lượng ban bố định tuyến đường với những router láng giềng. Chương thơm kết thúc với 1 phần thể hiện phương pháp BGP.. thêm các con đường IP vào bảng định tuyến của router dựa vào bảng BGP..

II. XÂY DỰNG QUAN HỆ BGP

Các nhẵn giềng BGP có mặt một liên kết TCP.. với các trơn giềng không giống, gửi các thông điệp BGP bên trên kết nối này, dẫn đến đỉnh điểm là những thông điệp cập nhật BGP. chứa những lên tiếng định con đường.

Mỗi router thông số kỹ thuật tường minh can dự của router nhẵn giềng, cần sử dụng các quan niệm này để báo cho router các liên tưởng nào bắt buộc cố gắng cấu hình thiết lập một liên kết TCP. Ngoài ra, trường hợp một router nhận ra một đề xuất thiết lập kết nối TCPhường (đến cổng TCPhường 179) xuất phát từ một can dự mối cung cấp ko được thông số kỹ thuật nlỗi nhẵn giềng BGP.., router vẫn lắc đầu thử khám phá này.

Sau khi liên kết TCP được tùy chỉnh thiết lập, BGPhường bắt đầu bởi thông điệp BGP xuất hiện. lúc một cặp thông điệp BGP.. xuất hiện đã có đàm phán, các router láng giềng đã có được tâm trạng tùy chỉnh thành công (established), là tâm trạng ổn định của nhị router chạy BGPhường sẽ chuyển động.

Ở thời điểm này, những thông điệp update BGPhường hoàn toàn có thể được điều đình. Phần tiếp đến đang bình chọn nhiều cụ thể về giao thức cùng giải pháp thông số kỹ thuật nhằm ra đời quan hệ tình dục bóng giềng BGPhường.

Đặc tính BGP

Mô tả cùng giá trị

Cổng TCP

179

Thiết lập khoảng thời gian duy trì và thời hạn hết hạn sử dung. Dùng lệnh bgp timers keepalive sầu holdtime vào chế độ thông số kỹ thuật router cùng neighbor timers đến từng router nhẵn giềng

Mặc định bởi 60 giây và 180 giây. Định nghĩa khoảng thời gian thân các thông điệp gia hạn với khoảng chừng thời hạn im re có nghĩa là láng giềng không vận động nữa.

Điều gì làm cho một router nhẵn giềng là iBGP?

Router bóng giềng trong cùng AS.

Điều gì khiến cho một router trơn giềng là eBGP?

Router nhẵn giềng không giống AS

Router ID trong BGPhường được xác minh như thế nào?

Theo thiết bị tự:

Lệnh bgp router-id.

Xem thêm: Guide Poppy Mã¹A 11: BảNg NgọC Bổ Trợ Vã  Cã¡Ch Lãªn đÁ»“ Cho Tæ°Á»›Ng Poppy

Địa chỉ IPhường. tối đa của cổng loopback sinh sống thờI điểm các bước BGP khởi cồn.

Địa chỉ IPhường. cao nhất của một cổng như thế nào đó sống thời khắc các bước BGPhường. khởi hễ.

Địa chỉ IP mối cung cấp được dùng để cho một router bóng giềng được khẳng định bằng phương pháp nào?

Định nghĩa bởi câu lệnh neighbor update-source hoặc ở chế độ mặc định, liên quan của cổng ra dùng làm đi cho router láng giềng.

Địa chỉ đích được dùng để cho láng giềng được xác minh như thế nào?

Định nghĩa tường minc bằng câu lệnh neighbor

Tính năng auto-summary

Mặc định là tắt. Bật lên bởi câu lệnh auto-summary

Xác thực cùng với router láng giềng

Chỉ cung ứng MD5, cần sử dụng câu lệnh neighbor password


1.Các router láng giềng nội vùng

Một router BGP xem một bóng giềng là giao diện nội vùng iBGPhường hay như là 1 nhẵn giếng ngoại vùng eBGP.. Hai phong cách router nhẵn giềng chỉ khác nhau chút xíu khi có mặt dục tình láng giềng. Sự biệt lập trnghỉ ngơi nên đáng chú ý khi xem xét ảnh hưởng của hình trạng quan hệ nam nữ lên quá trình cập nhật với bài toán chế tạo các đường trong bảng định đường.

Các router hình trạng iBGP. thường được sử dụng liên hệ những cổng loopback nhằm quan hệ tình dục BGP đạt được tính định hình cao. Bên trong một AS, sơ đồ vật kết nối đồ dùng lý thường sẽ có ít nhất hai đường thân từng cặp router. Nếu router chạy BGPhường cần sử dụng can hệ cổng mang đến kết nối TCP.. cùng nếu cổng kia bị hư, vẫn còn đấy một tuyến phố giữa nhị router, nhưng lại kết nối TCP. cũng biến thành thất bại.

Bất cđọng cơ hội như thế nào hai router BGP.. có nhiều hơn một đường đi trải qua đó nó rất có thể cho router khác, câu hỏi cần sử dụng cổng loopbaông chồng là hợp lý tuyệt nhất. lấy ví dụ như thứ nhất mô tả vài ba thông số kỹ thuật BGP.. cơ bạn dạng mang lại quan hệ nam nữ iBGPhường. R1, R2 và R3 trong AS 123, cùng với những điểm sáng sau:

Ba router vào AS 123 đang sinh ra quan hệ nam nữ iBGP.. với nhau tương đối đầy đủ (full mesh).R1 đã dùng lệnh bgp router-id nhằm thông số kỹ thuật RID của chính nó chứ không dùng cổng loopbaông chồng.R3 dùng thông số kỹ thuật peer-group cho nhị láng giềng R1 và R2. Vấn đề này có thể chấp nhận được sử dụng không nhiều lệnh cấu hình hơn cùng cách tân hiệu xuất xử trí bằng cách sẵn sàng có một tập đúng theo những gói tin cập nhật đến từng team trơn giềng. Các update kiểu như nhau được gửi ra toàn bộ các nhẵn giềng trong team nhẵn giềng.Quan hệ giữa R1 cùng R3 dùng đảm bảo BGPhường là MD5 cùng là kiểu đúng đắn độc nhất được hỗ trợ vào IOS của Cisteo.

*

Hình 12.2: Sơ đồ vật mạng thực hiện BGP

Cấu hình R1

R1 sẽ gán đúng đắn can dự nguồn update-source bằng cực hiếm 1.1.1.1 cho cả R2 với R3 để hoàn toàn có thể tương thích đúng cùng với câu lệnh neighbor trên R2 cùng R3. Ba cái đầu tiên trong thông số kỹ thuật ko được nhập lệ mà lại các loại này được tự động hóa chế tạo theo mang định của IOS phiên bản 12.3. Thật ra, IOS phiên phiên bản 12.3 chỉ ra rằng chính sách sync với auto-summary của 12.2 sẽ biến đổi thanh lịch no sync cùng no auto-summary Khi chuyển qua 12.3. Ngoài ra, R1 biết rằng láng giềng 2.2.2.2 với 3.3.3.3 là những iBGPhường. cũng chính vì giá trị remote-as đúngbởi quý hiếm AS trong câu lệnh router BGP.

Interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

router bgp 123

no synchronization

bgp router-id 111.111.111.111

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 123

neighbor 2.2.2.2 update-source Loopback1

neighbor 3.3.3.3 remote-as 123

neighbor 3.3.3.3 password secret-pw

neighbor 3.3.3.3 update-source Loopback1

no auto-summary

Cấu hình R3

R3 cần sử dụng một đội được điện thoại tư vấn là my-as nhằm kết hợp những lệnh liên quan mang đến R1 cùng R2. Chú ý rằng chưa hẳn tất cả các thông số mọi nằm trong peer-group: R3-R2 không dùng đúng đắn cơ mà R3-R1 thì gồm do vậy câu lệnh neighbor password ko được đặt vào peer-group nhưng lại được đặt vào câu lệnh neighbor 1.1.1.1.

interface Loopback1

ip address 3.3.3.3 255.255.255.255

!

router bgp 123

no synchronization

bgp log-neighbor-changes

neighbor my-as peer-group

neighbor my-as remote-as 123

neighbor my-as update-source Loopback1

neighbor 1.1.1.1 peer-group my-as

neighbor 1.1.1.1 password secret-pw

neighbor 2.2.2.2 peer-group my-as

no auto-summary

tiếp đến R1 gồm nhì nhẵn giềng được cấu hình thiết lập nhưng lại trạng thái “established” không phải bởi vì tinh thần chỉ ra rằng trong cột State/PfxRcd. Khi được tùy chỉnh cấu hình, cột này sẽ liệt kê số hệ trọng mạng được học thông qua những cập nhật BGP nhận ra từ từng router bóng giềng. Cũng chăm chú rằng R1 được cấu hình router ID và router ID ko được dùng như là liên can nguồn cập nhật.

R1# show ip bgp summary

BGPhường router identifier 111.111.111.111, local AS number 123

BGPhường table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

2.2.2.2 4 123 59 59 0 0 0 00:56:52 0

3.3.3.3 4 123 64 64 0 0 0 00:11:14 0

Một vài ba đặc điểm là đặc biệt quan trọng đặc biệt vào ví dụ bên trên.

Đầu tiên, chú ý rằng thông số kỹ thuật không chỉ ra một láng giềng là iBGP. tốt eBGP.. Thay vào đó, mỗi router sẽ chất vấn chỉ số ASN vào câu lệnh router bgp và đối chiếu với mức giá trị ASN vào câu lệnh neighbor remote-as của router trơn giềng. Nếu nhị quý hiếm này là như là nhau, quan hệ là iBGP và còn nếu không như là, quan hệ nam nữ là eBGP..R3 trong ví dụ trên cũng biểu hiện cách dùng lệnh tổng hợp lệnh peer-group để giảm những lệnh cấu hình. Peer-group của BGPhường. ko có thể chấp nhận được ngẫu nhiên những cấu hình BGP bắt đầu làm sao. Tổ hòa hợp lệnh peer-group chỉ dễ dàng chất nhận được chúng ta đội những câu lệnh neighbor vào cùng một tổ cùng tiếp đến vận dụng vào bóng giềng dùng lệnh neighbor peer-group.Thêm vào đó, BGP thành lập một tập thích hợp những thông điệp cập nhật mang đến peer-group, áp đặt các chế độ định đường đến tổng thể nhóm, chứ quán triệt từng router. Vì vậy nguyên lý này góp giảm giá thành tổn định giải pháp xử lý cùng bộ nhớ.

2.Các router BGPhường bóng giềng ngoại vùng

Kết nối đồ lý giữa các bóng giềng eBGPhường hay là 1 trong những mặt đường truyền, chủ yếu là vì kết nối được tiến hành giữa những đơn vị khác biệt trong số AS không giống nhau. Kết trái là, eBGP.. rất có thể chỉ cần sử dụng một liên can làm sao kia để tham gia phòng, bởi vì trường hợp con đường truyền bị sự núm, liên kết TCPhường cũng trở nên bị rớt. Hiện giờ không thể một tuyến đường thân những router.

lấy một ví dụ vào hình 12.2, quan hệ giới tính eBGP.. R1-R6 sử dụng địa chỉ cổng định nghĩa trong câu lệnh neighbor. Lúc có kết nối dự trữ IP. tồn tại giữa nhì bóng giềng eBGP, lệnh neighbor phải dùng ảnh hưởng cổng loopbaông chồng nhằm tận dụng tối đa khả năng dự phòng kia. lấy một ví dụ nếu như tất cả hai tuyến đường truyền tuy vậy song mãi sau giữa R3 với R4. khi câu lệnh neighbor tham mê chiếu thúc đẩy cổng loopbaông xã, cơ mà liên kết TCP vẫn mãi mãi. ví dụ như này có thêm vào vài ba câu lệnh, hiển thị biện pháp cần sử dụng cổng loopback thân R3 với R4 với biện pháp sử dụng can dự cổng thân R1 cùng R6. Lưu ý, ví dụ này chỉ hiển thị rất nhiều lệnh được tiếp tế so với ví dụ trước

Cấu hình R1

router bgp 123

neighbor 172.16.16.6 remote-as 678

R1 không tồn tại thông số kỹ thuật câu lệnh neighbor 172.16.16.6 update-source. R1 sẽ dùng liên quan cổng s0/0/0.6, liên tưởng 172.16.16.1 cũng chính vì lối đi của R1 về 172.16.16.6 cần sử dụng cổng s0/0/0.6 nhưng lại là cổng ra.

R1# show ip route 172.1.16.6

Routing entry for 172.16.16.0/24

Known via "connected", distance 0, metric 0 (connected, via interface)

Routing Descriptor Blocks:

* directly connected, via Serial0/0/0.6

Route metric is 0, traffic chia sẻ count is 1

R1# show ip int brief | include 0/0/0.6

Serial0/0/0.6 172.16.16.1 YES manual up up

Cấu hình R3. Bởi vị R3 chỉ mang lại cổng loopbachồng của R4 (4.4.4.4) với R4 là một trong những trơn giềng eBGPhường, R3 cùng R4 đã phân phối câu lệnh neighbor ebgp-multihop 2. Lệnh này gán giá trị TTL bằng 2. Nguồn cập nhật của R3 (update source) cần được chỉ ra rằng như là cổng loopbachồng để đúng bằng câu lệnh neighbor 3.3.3.3 trên R4.

router bgp 123

neighbor 4.4.4.4 remote-as 45

neighor 4.4.4.4 update-source loopback1

neighbor 4.4.4.4 ebgp-multihop2

Lúc này R3 tất cả cha router láng giềng vẫn chuyển động. Cũng để ý rằng tất cả tía liên kết TCP, mỗi kết nối cho từng trơn giềng BGP.. Crúc ý rằng bởi vì R3 được liệt kê sử dụng cổng hễ với R4 sử dụng cổng 170, đề nghị ta thấy thật ra R3 vẫn khởi tạo nên liên kết mang lại R4.

R3# show ip bgp summary

BGP router identifier 3.3.3.3, local AS number 123

BGPhường table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

1.1.1.1 4 123 247 247 0 0 0 03:14:49 0

2.2.2.2 4 123 263 263 0 0 0 03:15:07 0

4.4.4.4 4 45 17 17 0 0 0 00:00:11 0

R3# show tcp brief

TCB Local Address Foreign Address (state)

649DD08C 3.3.3.3.179 2.2.2.2.43521 ESTAB

649DD550 3.3.3.3.179 1.1.1.1.27222 ESTAB

647D928C 3.3.3.3.21449 4.4.4.4.179 ESTAB

Cấu hình eBGPhường thì không giống cùng với thông số kỹ thuật iBGPhường. ngơi nghỉ vài điểm nhỏ. trước hết, câu lệnh neighbor remote-as tđắm say chiếu mang đến một AS không giống với AS trong câu lệnh router bgp thì router trơn giềng là eBGP.. Thđọng hai, R3 bắt buộc thông số kỹ thuật câu lệnh neighbor 4.4.4.4 ebgpmultihop 2 và R4 cũng buộc phải bao gồm câu lệnh tương tự như, nếu như không kết nối không được hiện ra.

Xem thêm: Cách Trồng Lan Báo Hỷ Nở Hoa Đẹp Đúng Dịp Tết, Bí Quyết Trồng Lan Báo Hỷ Ra Bông

Đối với những thông số kỹ thuật eBGP, IOS của Cisteo mang định sử dụng ngôi trường TTL của gói tin có giá trị bởi 1, dựa vào một trả thiết rằng tương tác cổng kết nối trực tiếp sẽ tiến hành sử dụng vào thiết lập quan hệ giới tính, giống như R1-R6 vào ví dụ bên trên. Trong ví dụ này, trường hợp R3 không cần sử dụng công dụng nhiều chặng (multihop), nó sẽ gửi gói tin cho R4 với TTL 1. R4 vẫn nhấn gói tin (TTl 1 ngơi nghỉ thời gian đó) với tiếp đến cố gắng định tuyến đường gói tin cho cổng loopbaông xã của nó. Động tác này sẽ trừ TTL về 0, tạo cho R4 loại bỏ gói tin. Vì vậy trong cả Khi router chỉ có giải pháp 1 chặng, hãy coi cổng loopbachồng là sinh sống đầu xa của kết nối, rất cần được gồm cấp dưỡng các khoảng.


Chuyên mục: Kiến thức