Ipv6 Là Gì


*

IPv6 là gì

Lịch sử thành lập và hoạt động của IPv6 (từ viết tắt của mạng internet Protocol 6) hơi lâu. Đó là vào khoảng thời gian 1981, khi những máy tính phần nhiều chỉ có thể truy cập internet giao hàng cho các tổ chức nghiên cứu và phân tích quân sự. Với môi trường thao tác 8 bit, kết hợp với không gian add 32 bit bởi vì phiên bản Internet Protocol 4 (viết tắt là IPv4) cung cấp cho phép kết nối cho tới 4 tỷ add khác nhau. 

Trải qua ngay gần 30 năm, sự cải cách và phát triển của technology đã chế tác bước đột nhiên phá, internet tồn tại trên khắp vắt giới khiến cho con số showroom đã gần đến mức cực đại. Đồng thời, nó còn dự báo rất có thể vượt số lượng giới hạn của IPv4. Về lý thuyết, trường hợp vượt mức nai lưng thì kĩ năng kết nối internet sẽ không còn thể vận động được. Chính vấn đề này đã thúc đẩy việc nghiên cứu, cải cách và phát triển giao thức mới, giúp giảm bớt nhược điểm trên.

Bạn đang xem: Ipv6 là gì

Đầu trong năm 1990, IETF phát triển một giao thức mới có tên gọi là IP Next Generation (IPng). Và vào thời điểm năm 1998, giao thức này chính thức chuẩn chỉnh hóa, được Tổng doanh nghiệp Internet mang đến tên miền với số (viết tắt là ICANN) phê duyệt, có thể chấp nhận được sử dụng trên thoáng rộng trên toàn cầu. Giao thức được đặt tên IPv6 (RFC 1883).

IPv6 ra đời đã giải quyết và xử lý được những giảm bớt tồn trên của IPv4 trong khối hệ thống internet, tạo ra bước tiến dancing vọt của technology số.

Các điểm cải tiến của IPv6 so với IPv4:

không gian lưu trữ lớn. IPv4 có không gian truy cập 32 bit, tương đương 4 tỷ địa chỉ. Còn IPv6 có không gian là 128 bit, to hơn gấp 4 lần so với IPv4. Độ bảo mật cao hơn. Tài năng định con đường được tăng cao. Cấu hình được xây dựng theo hướng dễ dàng hơn đối với IPv4.

Lợi ích của IPv6 connectivity

Các công dụng mà IPv6 đã và đang với đến cho tất cả những người dùng kia là:

cho phép không gian showroom lớn, giúp việc cai quản không gian này trở nên tiện lợi hơn. Quản lí trị dễ ợt hơn. Bởi IPv6 có khả năng auto cấu hình nhưng mà không đề nghị đến máy chủ DHCP. Trong lúc đó, IPv4 yêu cầu DHCP để cấu hình. Định con đường IPv6 được thiết kế phân cấp nên cấu tạo tốt. IPv6 cung ứng tốt rộng về Multicast. Việc bố trí và định hình header được triển khai khoa học tập và về tối ưu giúp bài toán bảo mật thông tin được cải tiến hơn. IPv6 hỗ trợ tốt cho các thiết bị di động.

Cấu trúc địa chỉ IPv6

Cấu trúc của IPv6

Cấu trúc của một IPv6 tất cả 128 bit, được chia thành 8 nhóm. Vào đó, từng nhóm có 16 bit cùng được phân loại bởi vết “:”.

Một địa chỉ IPv6 được biểu đạt theo cấu tạo sau:

FEDC:BA98:768A:0C98:FEBA:CB87:7678:1111:1080:0000:0000:0070:0000:0989:CB45:345F

Vì cấu trúc quá lâu năm nên người ta thường vứt số 0 ở đầu từng nhóm nhằm rút gọn. Đối với đội nào chỉ gồm duy nhất dãy số 0 thì nó sẽ tiến hành biểu diễn bởi dấu “::”

*

Cấu trúc của Address Prefixes

Address Prefixes có cấu tạo tương trường đoản cú IPv4 CIDR. Biện pháp thể hiện của nó là IPv6-address/ prefix-length. 

Trong đó:

- IPv6-address: Địa chỉ IPv6 với giá trị bất kỳ.

- Prefix-length: Số bit tiếp giáp nhau vào prefix.

Ví dụ: Quy tắc màn biểu diễn của 56 bit prefix 200F00000000AB là

200F::AB00:0:0:0:0/56

200F:0:0:AB00::/56

Lưu ý: Với add IPv6, kí hiệu “::” chỉ được dùng duy tốt nhất 1 lần vào một sự biểu diễn.

Các nguyên tố của IPv6

Địa chỉ IPv6 có 3 thành phần: site prefix, subnet ID cùng interface ID. Trong đó:

Site prefix: Đây là thông số kỹ thuật được gán với website trải qua ISP. Vì đó, toàn bộ máy tính ở cùng vị trí sẽ share với nhau bằng một site prefix. Rất có thể thấy, tính năng của site prefix là khi đã nhận được ra mạng của người tiêu dùng và cho phép truy cập thông qua internet thì nó sẽ tìm hiểu việc sử dụng chung. Subnet ID: Đây là thành phần bên trong website. Nó được sử dụng để miêu tả cấu trúc site của mạng. Do thế, một IPv6 subnet sẽ có cấu tạo tương đương một nhánh mạng đơn. Interface ID: kết cấu của nó giống như ID trong IPv4. Các thông số kỹ thuật sẽ nhấn dạng một host riêng. Interface ID có thông số kỹ thuật tự động. 

Ví dụ: Địa chỉ IPv6 gồm cấu trúc: 2001:0f68:0000:0000:0000:0000:1986:69af bao gồm:

- Site prefix: 2001:0f68:0000

- Subnet ID: 0000

- Interface ID: 0000:0000:1986:69af
*

Phân loại địa chỉ IPv6 connectivity

Có 3 loại add IPv6:

Unicast: Một địa chỉ Unicast được chỉ định và hướng dẫn riêng cho một cổng của node IPv6. Khi tất cả một gói tin gởi đến địa chỉ cửa hàng Unicast, nó sẽ được đưa tới cổng đã hướng dẫn và chỉ định bởi địa chỉ cửa hàng đó. Multicast: Đây là nhóm những cổng IPv6. Khi 1 gói tin gửi đến địa chỉ Multicast thì nó vẫn được tổng thể thành viên trong đội multicast xử lý. Anycast: Đây là showroom đăng ký cho những cổng (tức trên những node). Khi có chương trình tin giữ hộ đến add Anycast, nó sẽ tiến hành chuyển mang lại một cổng bất kỳ, mặc dù nhiên, đa số là đến cổng sát nhất.

Hướng dẫn cách đặt địa chỉ cửa hàng IPv6 cho win 7, 8, 10

Để đặt add Ipv6 mang lại win 7, 8, 10, bạn triển khai như sau:

cách 1: Click vào biểu tượng Window, chọn tiếp Run. Trong cửa sổ Run, nhập mẫu chữ ncpa.cpl. Cách 2: các bạn chọn thẻ mạng ước ao gán IPv6, tiếp đến chọn tiếp Properties. Cách 3: tiếp tục chọn internet Protocol Version 6 (TCP/IPv6), rồi chọn Properties.
*
bước 4: Bạn tiến hành điền các thông số kỹ thuật giá trị IPv6 ở trong nhà cung cấp cho (tham khảo hình mặt dưới). 
*
bước 5: sử dụng câu lệnh ipconfig ở cmd để thực hiện ping kiểm tra kết quả IPv6. Bởi cách, mở cmd, gõ tiếp lệnh ipconfig. Cơ hội này, một hành lang cửa số hiển thị như hình sau.
*

Kế đến, áp dụng dòng lệnh ping -6 ipv6.google.com để khám nghiệm IPv6:

*

Nếu hệ thống hiển thị tác dụng trả lời tức là bạn đã cài đặt thành công showroom IPv6.

Hướng dẫn cách sử dụng IPv6 - đặt địa chỉ cửa hàng IPv6 thông qua Remote UI

Các làm việc thực hiện nay đặt địa chỉ IPv6 bằng phương pháp sử dụng Remote UI được thực hiện như sau:

bước 1: bạn khởi đụng Remote UI với đăng nhập vào hệ thống. Cách 2: Click chọn thư mục Setting/Registration sinh sống cột bên bắt buộc như hình sau.
*
bước 3: vào bảng hiện tại ra, click lựa chọn Network Setting, rồi lựa chọn tiếp TCP/ IP Settings.
*
cách 4: tại mục IPv6 Setting, bạn click lựa chọn Exit.
*
bước 5: từ bây giờ một bảng thoại xuất hiện. Chúng ta chọn hộp kiểm soát rồi tiến hành cấu hình cài đặt.
*
cách 6: Khi vẫn hoàn tất setup ở bước 5, các bạn click OK nhằm kết thúc thiết đặt IPv6.

Cấu hình IPv6 trên Router Cisco

Các bước tiến hành như sau:

cách 1: Tiến hành cấu hình IPv4, giao thức OSPFv2 trên các Router Thename cùng Thename1. Đây là hầu như tên router mang định mà lại Hosting Việt đặt đến ví dụ minh họa sau để chúng ta dễ hiểu. Trong thực tế, chúng ta cũng có thể đặt tên tùy ý theo nhu cầu sử dụng.

- Thename: 

Cú pháp câu lệnh thực hiện:

Thename#config terminal

Thename(Config)#interface fastethernet 0/0

Thename(Config-if)#ip address 192.168.12.1 255.255.255.0

Thename(Config-if)#no shut

Thename(Config-if)#interface loopback 0

Thename(Config-if)#ip address 1.1.1.1 255.255.255.255

Thename(Config-if)#no shut

Thename(Config-if)#interface fastethernet 0/1

Thename(Config-if)#no ip address

Thename(Config-if)#ipv6 enable

Thename(Config-if)#ipv6 address 2000::1/64

Thename(Config-if)#no shut

Thename(Config-if)#exit

Thename(Config)#router ospf 100

Thename(Config-router)#network 1.1.1.1 0.0.0.0 area 0

Thename(Config-router)#network 192.168.12.0 0.0.0.255 area 0

- trên ISP:

Cú pháp câu lệnh:

ISP#config terminal

ISP(Config)#interface fastethernet 0/0

ISP(Config-if)#ip address 192.168.12.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#interface fastethernet 0/1

ISP(Config-if)#ip address 192.168.23.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#exitISP(Config)#router ospf 100

ISP(Config-router)#network 192.168.12.0 0.0.0.255 area 0

ISP(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Hình sau là bảng định con đường IPv4 trên Thename.

Xem thêm: Biển Số Xe 74 Ở Đâu ? Mã Theo Từng Huyện Là Gì

*

- Thename1

Cú pháp câu lệnh:

Thename1#config terminal

Thename1(Config)#interface fastethernet 0/0

Thename1(Config-if)#ip address 192.168.23.3 255.255.255.0

Thename1(Config-if)#no shut

Thename1(Config-if)#exit

Thename1(Config)#router ospf 100

Thename1(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Dưới đấy là bảng định tuyến IPv4 bên trên Thename1.

*

Lúc này, những mạng IPv4 đã hoàn toàn có thể thấy và kết nối với nhau.

cách 2: tạo nên interface tunnel 0 bên trên Thename với Thename1 

- Thename

Câu lệnh:

Thename(config)#ipv6 unicast-routing

Thename(config)#interface tunnel 0

Thename(config-if)#ipv6 address 3000::1/64 eui-64

Thename(config-if)#no ipv6 nd suppress-ra

Thename(config-if)#tunnel source loopback 0

Thename(config-if)#tunnel mode ipv6ip isatap

Để chất vấn Tunnel vừa tạo, bạn dùng lệnh show ipv6 interface brief.

*

Theo hình trên, Thename có showroom IPv6 của tunnel 0 là 3000::5EFE:101:101

- Thename1:

Cú pháp câu lệnh như sau:

Thename1(Config)#interface tunnel 0

Thename1(Config-if)#ipv6 enable

Thename1(Config-if)#ipv6 address autoconfig

Thename1(Config-if)#tunnel mode ipv6ip

Thename1(Config-if)#tunnel source fastethernet 0/0

Thename1(Config-if)#tunnel destination 1.1.1.1

Để kiểm soát tunnel 0 vừa tạo, các bạn cũng triển khai câu lệnh tựa như như bên trên là cần sử dụng lệnh show ipv6 interface brief.

*

Theo bảng trên, địa chỉ cửa hàng IPv6 của tunnel0 bên trên Thename1 là 3000::C0A8:1703

cách 3: triển khai định tuyến tĩnh trên các router IPv6 để các mạng nhỏ thấy nhau, bằng cách dùng câu lệnh ipv6 route x:x:x:x::x/ next-hop hoặc interface.

- Thename: Thename(config)#ipv6 route 4000::/64 3000::c0a8:1703

- Thename1: Thename1(config)#ipv6 route 2000::/64 3000::5efe:101:101

Sau đó, chúng ta kiểm tra các bảng định tuyến.

Hình sau là bảng định tuyến IPv6 bên trên Thename.

*

Dưới đấy là bảng định tuyến đường IPv6 trên Thename1.

*

bước 4: Thực hiện cài đặt IPv6 cho các host và ping để kiểm tra liên kết

Cách triển khai như sau:

- Đặt IPv6 cho laptop sử dụng Window Vista, 7, 8, 10, bạn thực hiện như trả lời cách đặt địa chỉ IPv6 sinh hoạt mục trên. Đó là vào Start / chọn Control panel / chọn tiếp Network and Internet / click chọn Network and Sharing Center /click mục Change adapter setting / và chọn Properties Local Area Connection / sau đó, click vào internet Protocol Version 6 để thiết lập đặt địa chỉ IPv6.

Đặt IPv6 cho laptop sử dụng Window XP: Click vào nút Start / gõ Cmd vào thanh kiếm tìm kiếm / kích hoạt kĩ năng IPv6 bằng cách gõ câu lệnh “netsh interface ipv6 install”. Sau đó, cần sử dụng tiếp lệnh “netsh interface ipv6 địa chỉ address “Local Area Connection” 2000::2/64” nhằm đặt địa chỉ IPv6.
*

Sau khi hoàn tất đặt địa chỉ cửa hàng IPv6 mang lại host, bạn thực hiện ping để đánh giá kết nối:

- Kiểm tra liên kết từ host 1 đến host 2

*

- Kiểm tra kết nối chiều ngược lại từ host 2 mang đến 1

*

Lúc này, 2 host vẫn thấy nhau. Đây là phía dẫn về phong thái dùng nguyên lý ISATAP tùy chỉnh cấu hình kết nối của IPv6 là gì. Mô hình mạng này tương đối dễ dàng và đơn giản và bạn dễ dãi mở rộng với nhiều router khác nhau, phối kết hợp sử dụng định tuyến cao cấp hơn.

Ngoài ra, các bạn cũng nên để ý là trước khi dùng ping để soát sổ kết nối, bạn phải bảo vệ Window Firewall đã có được tắt.